Sinds juli 2013 is de 5.3-tak van PHP EOL (End Of Life). Dat wil zeggen dat er vanuit PHP.net uitsluitend nog security updates worden verstrekt voor de 5.3-tak en er geen nieuwe functies meer worden toegevoegd. De opvolger, PHP 5.4, is al geruime tijd in gebruik en bevat nieuwe functies en enkele belangrijke verbeteringen ten opzichte van 5.3, waaronder significante snelheidswinst onder bepaalde omstandigheden.


 

Wat betekent dit voor mij?

Zoals gebruikelijk voert Zenid.net de nieuwe PHP-versie in fases in. Na initiële test- en daaropvolgende acceptatieprocedures, wordt PHP 5.4 in de maand januari 2015 volledig uitgerold op het shared hosting platform. In beginsel heeft dit geen nadelige gevolgen voor u. Er is slechts een beperkt aantal wijzigingen dat niet volledig compatible is met eerdere PHP-versies, maar met name van het verdwijnen van bepaalde -overbodig geworden- functies wordt al geruime tijd aangegeven via E_DEPRECATED meldingen. Als u recente (> 2012) versies gebruikt van populaire websoftware, dan hoeft u zich in principe geen zorgen te maken.

 

Uitgebreide informatie

Als webontwikkelaar kunt u terecht op de website van PHP.net. Daar vindt u een volledige lijst met migratietips. Heeft u toch nog vragen of problemen? Neem dan direct contact met ons op. Onze helpdesk staat voor u klaar!

 

Toch nog vragen

Mocht u nog vragen hebben, dan helpen wij u graag persoonlijk verder. U kunt uw vragen altijd e-mailen naar wij@zenid.net, maar wij staan u natuurlijk ook graag telefonisch te woord op het telefoonnummer 045 - 8887 103. Aarzel dus niet, maar neem direct contact met ons op!



Monday, November 10, 2014







« Terug